nftstorage.link DNS has been taken down
Incident Report for NFT Storage
Resolved
This issue has been resolved. Thanks for your patience.
Posted Jun 14, 2022 - 23:34 UTC
Identified
Our domain registrar has taken down nftstorage.link because users were using it for phishing content. However, this should be out of the scope of a domain registrar's responsibilities, and we are working with them to resolve this issue. We do not currently have an estimated time for resolution. We recommend using the ipfs.io or dweb.link gateway in the meantime if that is an option (learn more about gateways at https://docs.ipfs.io/concepts/ipfs-gateway/).
Posted Jun 14, 2022 - 22:27 UTC
This incident affected: nftstorage.link (IPFS Gateway).