Slowness and timeouts
Incident Report for NFT Storage
Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 21:25 UTC
Investigating
We are experiencing degraded performance and connectivity issues. We are actively scaling our infrastructure to handle current load
Posted Dec 05, 2022 - 17:22 UTC
This incident affected: Upload API and Website.