nftstorage.link gateway blocked by Google
Incident Report for NFT Storage
Resolved
This incident has been resolved. We will be publishing a blog post next week (that was coincidentally already in the works) about our learnings, and hopefully help drive the conversation to make a better web with web3.
Posted Apr 21, 2022 - 22:58 UTC
Monitoring
It appears that nftstorage.link works again in Chrome and software using the Chrome Safe Browsing list. We did not receive explicit confirmation from Google yet, so we are monitoring for a while before calling the issue resolved.
Posted Apr 21, 2022 - 22:39 UTC
Identified
Google has blocked the entire nftstorage.link domain, affecting all browsers using the Chrome denylist (e.g., Google Chrome). We have blocked the bad CID they identified and are waiting for them to accept our request. They had previously assured us that the entire domain would not be blocked because of isolated bad content, and we will continue working with them to make sure this actually happens. In the meantime, all content is available using other gateways, like dweb.link (https://ipfs.github.io/public-gateway-checker/).
Posted Apr 21, 2022 - 18:43 UTC
This incident affected: Website.