Login issues
Incident Report for NFT Storage
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 12:58 UTC
Update
We are continuing to investigate this issue.
Posted Sep 28, 2022 - 18:24 UTC
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 18:23 UTC
This incident affected: API and Website.